Friday, August 10, 2007

Firefox Users!

I've gone into the template and changed everything in the HTML colour white (ffffff) to black (000000), hoping for the best ;-) (seeings as I couldn't pinpoint exactly which part was giving the problems - not very good at all this HTML stuff am I!)

Has this solved the problem? I hope so.

Karen & Isabelle: thanks you two for all your help and suggestions (and pointing it out to me, or I'd never have known). :-)


Thanks everyone for your comments on Seasons in the Square. And yes, I do hope to frame them all the same and hang them together. Hopefully by the end of the year.

11 comments:

Isabelle said...

Yep that did solve the problem perfectly Concetta :) On behalf of all Firefox uses, thank you! :D

Isabelle said...

oops, I meant users ;)

Niamh said...

The problem is your background. In ie the background will repeat down the page, in firefox it doesn't.

I'm at work at the moment, but when I get home (in about an hour) I will have a look at the code on the template and tell you where to fix it.

It's not your fault at all, it's a problem with the template itself and the person who coded it.

KarenV said...

Thanks Tina, that's much better :) Hopefully Niamh (above comment) can sort out the coding error for you too.

Niamh said...

Okay fixed it for you...

In your template (near the top) you have the following code...

A:hover{color:#000000; background-color: #B488B6; text-decoration:underline overline; }
}
body {
background : #ffffff url('http://img167.imageshack.us/img167/3809/muchtotellbghx7.jpg') repeat-y 0px 0px;
scrollbar-arrow-color:#63446E;

There is an extra } between the A:hover line and body {

So it should read...

A:hover{color:#000000; background-color: #B488B6; text-decoration:underline overline; }

body {
background : #ffffff url('http://img167.imageshack.us/img167/3809/muchtotellbghx7.jpg') repeat-y 0px 0px;
scrollbar-arrow-color:#63446E;
scrollbar-base-color:#000000;

That will fix the background problem in firefox and other browsers.

IE is very forgiving when it comes to messed up code and will pretty much assume how it should be. Firefox and other browsers read the code literally, and the extra } is what broke the background.

Many people say that it is firefox that doesn't read the template correctly, when it is actually the other way round.

And I will stay off my high horse... this time... about designers who don't test their templates across all browsers, and instead will say it's about time I got myself in gear and started making my own linkware templates again.

elenamac said...

I'vent firefox but the new look of the blog is simply wonderful!!
Well Done!

Love
elena

Kathy said...

Wow your Seasons in Squares look fabulous, and love the new look of your blog.

Hugs xxxxx

Jeanne said...

I was catching up on several of your blog entries Tina. I love your Just Nan squares, the Baby Garden, Rose, and your other finishes. Your new blog template looks great to me. (I need a new one too) Congratulations on all your progress!

Laura said...

love the new look...lilac is my favourite colour

lena-lou said...

Ooooh love the new template you have here :-)) Loved admiring your stitching beneath too !!

Have a great weekend :)

Eleni said...

Came back from holidays and decided to drop by ... love the new look, and love those Just Nan squares ... you are probably very busy now eh? :D